VirtueMart

WooCommerce

Others

Docs

Support

Demo

Blog

About

Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: Unable to update through plugin page

Unable to update through plugin page 10 Apr 2017 20:40 #1

1) php error at the top of the screen on the plugins page complaining about some .json file in your plugin folder
2) Unable to access plugin download URL. Please check your credentials. (Credentials are fine and so is the order number.. )
3) Check for updates results in "This plugin is up to date." even though I have version 1.3.8 installed and I see in the downloads 1.4 is available.

UPDATE: I've now upgraded manually to 1.4 through FTP. The plugin works and does what it is asked so did version 1.3.8 but the php error and my seemingly invalid credentials problem remains.
The administrator has disabled public write access.

Unable to update through plugin page 22 Apr 2017 18:19 #2

Dear Vision,
1) What is the exact php error message about that json file? AFAICS, there is no json file in our plugin folder. However, the update check works by requesting the information in JSON format from our servers. The exact wording of the error message can give a better insight into where the problem potentially lies.

2) If the plugin updater is not able to correctly download or interpret the update information from our servers (the problem in item 1), then this would be the logic consequence. So, let's first figure out the actual cause of item 1.

3) We have not yet switched the automatic update system to use version 1.4, as we'd like to get some real-world testing from new ussers before automatically switching the whole world to a new version.

So, could you please post the exact error message? And also your (a) WordPress version, (b) your WooCommerce version and (c) your PHP version.

Best regards,
Reinhold
The administrator has disabled public write access.

Unable to update through plugin page 15 Jun 2017 10:53 #3

Notice: Failed to parse plugin metadata. Try validating your .json file with jsonlint.com/ in /wp-content/plugins/woocommerce-advanced-ordernumbers/plugin-update-checker/plugin-update-checker.php on line 914
The administrator has disabled public write access.

Unable to update through plugin page 19 Jun 2017 01:12 #4

Dear Vision,
You are the third person to report this issue (the other two are: open-tools.net/forum/shipping-by-rules-f...tem-status-page.html and open-tools.net/forum/shipping-by-rules-f...383-fatal-error.html), but so far we have not been able to track down the issue or even reproduce it here on our machines...

Could you please follow the steps described in
open-tools.net/forum/shipping-by-rules-f...tatus-page.html#7955
and
open-tools.net/forum/shipping-by-rules-f...tatus-page.html#8003
to enable debugging in WordPress and (separately) in our plugin. Do you get some more debug output in the log file or on screen?

Alternatively, if you are comfortable with giving a stranger like me access to your admin backend, I could even do it myself on your site.

Best regards,
Reinhold
The administrator has disabled public write access.

Unable to update through plugin page 24 Jun 2017 23:01 #5

Dear Vision,
Can you please retry it? We have made some adjustements to the update system, which we hope will fix the issue.

Best regards,
Reinhold
The administrator has disabled public write access.

VM - Shopping cart

 x 

Cart empty

Login Formular