Notice: Only variables should be assigned by reference in /var/www/clients/client4/web20/web/templates/shape5_vertex/vertex/responsive/responsive_mobile_sidebar.php on line 8

Notice: Only variables should be assigned by reference in /var/www/clients/client4/web20/web/templates/shape5_vertex/vertex/responsive/responsive_mobile_menu.php on line 278

VirtueMart

WooCommerce

Others

Docs

Support

Demo

Blog

About

Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: [SOLVED] 6.2.1 to 6.2.2 update issue

6.2.1 to 6.2.2 update issue 11 Jun 2017 20:49 #1

Hello,
Update through Joomla backend integrated update management does not work.

Joomla 3.7.2
PHP 7.0.19
Virtuemart
VirtueMart 3.2.2

BRgds,
Bernard
The administrator has disabled public write access.

6.2.1 to 6.2.2 update issue 19 Jun 2017 01:01 #2

Dear bbiffi,
Sorry to hear you are running into problems. Could you please be a bit more specific than "does not work"?

What exactly does now work? Do you get an error message? Do you get a blank screen? Does the updater simply don't do anything? Does the plugin update appear to update, but the plugin still remains at the old version?

If there is an error / warning message, the exact wording of the message is the crucial part. Could you please copy the full message?

Thanks,
Reinhold
The administrator has disabled public write access.

6.2.1 to 6.2.2 update issue 06 Aug 2017 01:19 #3

Dear Bernard,
This is now a known problem with Joomla 3.7.x and affects basically all third-party VirtueMart plugins. In particular, the plugin updater of Joomla 3.7 tries to load the plugin before the update, but it does not load VirtueMart itself, so the plugin has several missing dependencies. Previous Joomla versions did not try to load a plugin before updating it.

We (VM core developers) are trying to find a proper solution directly in VirtueMart that fixes the issue for all plugins.

As a workaround, you can for now download the latest plugin file from our Homepage manually and install it with Joomla's plugin installer (don't remove the existing version!). This has more or less the same effect as the automatic update.

Best regards,
Reinhold
The administrator has disabled public write access.

6.2.1 to 6.2.2 update issue 06 Aug 2017 07:42 #4

Did it !
Thanks Reinhold,
Best Regards,
Bernard
The administrator has disabled public write access.

[SOLVED] 6.2.1 to 6.2.2 update issue 06 Aug 2017 07:43 #5

Problem solved.
The administrator has disabled public write access.

[SOLVED] 6.2.1 to 6.2.2 update issue 02 Sep 2017 18:08 #6

Just an update: The latest VirtueMart version now fixed the automatic updates for all VM plugins (including ours). So, as soon as you update VirtueMart (and in particular the VirtueMart AIO component), the automatic updates should work flawless again.

Best regards,
Reinhold
The administrator has disabled public write access.

[SOLVED] 6.2.1 to 6.2.2 update issue 14 Sep 2017 09:16 #7

After installation plg_opentools_vm_rules_shipping_advanced_v6.2.4 generete this error on my site:
Notice: Undefined property: plgVmShipmentRules_Shipping_Advanced::$helper in /home/tccgfgfu/t7.orissa.it/plugins/vmshipment/rules_shipping_advanced/rules_shipping_advanced.php on line 40
Fatal error: Call to a member function registerCallback() on null in /home/tccgfgfu/t7.orissa.it/plugins/vmshipment/rules_shipping_advanced/rules_shipping_advanced.php on line 40

PHP 5.6 VM 3.2.4 J 3.75

I have try to update AIO components but the error is
The administrator has disabled public write access.

[SOLVED] 6.2.1 to 6.2.2 update issue 18 Sep 2017 14:09 #8

Dear Orissa,
I suppose this issue has been solved by updating the free version to the latest version, too, as you mentioned in your other post?

The two versions share a lot of code, so when both versions are installed, it is important to keep both updated. Otherwise the advanced version might use some outdated code from an outdated free version installed.

Best regards,
Reinhold
The administrator has disabled public write access.

VM - Shopping cart

 x 

Cart empty

Login Formular